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1. INTRODUCTION 

 OVERVIEW 

Indigo ELN, the Open-Source Chemistry Electronic Lab Notebook, was developed within Pfizer, Inc. and 

is widely used by Pfizer scientists. 

Pfizer licensed the software code of Indigo ELN to EPAM Life Sciences (former GGA) in order to create 
and deliver an external, open source version of CeN Chemistry Electronic Lab Notebook (Pfizer’s Open-
Sourced ELN). 

Pfizer granted a license to EPAM to: 

 Install, use, modify, and create derivative works of CeN. 

 Allow its open source community of users to use CeN and the versions originating from this 
open-source code. 

 Distribute Indigo ELN to its users on a standalone basis and/or in conjunction with EPAM 
products and services. 

 Support Indigo ELN and its derivative works. 

Benefiting from the considerable investment by Pfizer in its internal chemistry ELN, Indigo ELN provides 
scientists with a proven way to create, store, retrieve, and share electronic records of chemistry and 
biology-related information in ways that meet all legal, regulatory, technical, and scientific 

requirements. 

Indigo ELN allows scientists to prepare, plan, and analyze experiments, access relevant information, 
and develop new methods using prior experience, in Synthetic Chemistry, Analytical Chemistry, and 
Process Chemistry. 

Through the use of Indigo ELN, you can upgrade your existing ELN with a proven and tested open-source 

platform, and you can do it at no charge. 

We hope that you will consider the use of Indigo ELN as it combines the best of two worlds: an 
application developed and refined at the world’s largest pharmaceutical company and tested by 

thousands of chemists there, and a price point that is not possible to beat. 

An electronic laboratory notebook is a system to create, store, retrieve, and share electronic records 
in ways that meet all legal, regulatory, technical and scientific requirements, while maintaining the 
responsibility of scientist for care and maintenance of laboratory records. 

This document describes the process of using Indigo ELN. 

 INDIGO ELN: CORE OPEN-SOURCE PACKAGE 

The Indigo ELN core open-source package offers: 

 Basic functionality of Indigo ELN without using any proprietary Pfizer services or commercial 
third-party products. 

 Basic functionality and user interfaces to create, describe, and manage singleton experiments 
and concept records. 

 Reaction rendering and chemical properties calculation based on EPAM’s chemoinformatics 
engine Indigo®. 

 Support of ISIS Draw for structure editing. 

The package includes the following components: 

 Simple User Management Tool. 

 Simple Signature Service to Sign and Witness Experiments. 

 APIs to integrate with existing customer services and databases. 
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EPAM can support customers in: 

 Integration with their services and databases. 

 Creation of new services. 

 SYSTEM ARCHITECTURE AND TECHNOLOGIES 

 

 INTEGRATION WITH EXTERNAL SERVICES 

 

Indigo 
ELN
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2. INDIGO ELN USER INTERFACE 

 FIRST START 

To learn about installing and configuring Indigo ELN, please see the Indigo ELN Installation Guide. 

The following picture shows the start of Indigo ELN. 

 

Figure 1. Starting Indigo ELN 

 LOGIN SCREEN 

To log into Indigo ELN, on the Login screen, type your username and password, and then click OK. 

 

Figure 2. Login screen 

 MAIN WINDOW 

The main window of Indigo ELN includes the following parts: 

 Navigation Pane – Displays notebooks arranged by sites and users and experiments grouped 
within Notebooks. 

 Work Area - Displays various tabbed views for working with the program. 

The window includes the following standard elements: 

 Title Bar identifies the owner. 

 Menu Bar accumulates menu commands. 

 Toolbar displays menu commands as icons. 

 Status Bar displays the progress bar, date, and memory used. 
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Figure 3. Indigo ELN main window 

 MENU COMMANDS 

2.4.1. Standard Commands 

Window menu 

 

Figure 4. Window menu 

Help menu 

 

Figure 5. Help menu 

For information about using the Health Check function, see Section 2.6. 
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2.4.2. Indigo ELN Specific Commands 

File menu 

The File menu includes commands to manage experiments: 

 

Figure 6. File menu 

Options menu 

The Options menu includes commands to set various program preferences and run search and signature 

routines: 

 

Figure 7. Options menu 

For information about using the Preferences command, see Section 2.5. 

 PREFERENCES 

Clicking Preferences on the Options menu opens the Preferences dialog box providing some settings 

for the program. Users can set up the following types of preferences: 

 Login setup, see Section 2.5.1. 

 Structure databases, see Section 2.5.2. 

 Therapeutic area and project codes, see Section 2.5.3. 
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2.5.1. Log-in Setup Preferences 

 

Figure 8. Log-in Setup Preferences tab 

2.5.2. Structure Databases 

This option is disabled in the current version since the software operates with a single structure 

database. 

2.5.3. Therapeutic Area and Project Code 

 

Figure 9. Therapeutic Area & Project Code tab 
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 HEALTH CHECK SUMMARY 

Clicking Health Check on the Help menu opens the System Health Check Dialog window displaying 

operability of the system components: 

 

Figure 10. System Health Check window 

3. INDIGO ELN FUNCTIONALITY OVERVIEW 

 MAJOR FUNCTIONS 

 The major functions of Indigo ELN are the following:Browse experiments 

 Create and set up a Singleton Experiment and Concept Record page 

 Set up the run Experiment & Record Results 

 Upload analytical information* 

 Retrieve analytical information* 

 Register and submit batches automatically 

 Sign and witness Experiment* 

 Attach documents 

 Print report and offline access 

 Search in Indigo ELN 

* Functionality that works only after integration with the corresponding services. 
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 BROWSING EXPERIMENTS 

Selecting an experiment in the left pane of the Main window opens the experiment data in the 

Experiments tab of the Work area of the window. 

 

Figure 11. Experiment tab in the Work area 

Users can collapse/expand/close the experiment using standard Windows controls. 

Note 
Users can open more than one experiment at a time, but try to avoid having too many open as it 
slows performance and could potentially exceed your computer’s available memory. 

Tabs provide sections to enter data for the major tasks: experimental setup data, product batches 

data, analytical results, registration and submission of products, and attached documents. 

Within each tab, sections divided by title bars subdivide the data. Click anywhere on a title bar to 
expand/collapse that section. 
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The following are the tabs to manage experiments in the Work area: 

 Experiment – allows users to describe general information of experiment, set Reaction schema, 
execute Stoichiometry calculations with reactant, Reagent, and Solvents. See Figure 11 

 Batches - allows users to define synthesized products, document their yields, purity, and other 
properties. See Figure 12. 

 

Figure 12. Batches tab 

 Analytical - allows users to upload PDF documents with analytical results or retrieve such 
information from external databases using NMB batch number as a reference. 

Note 
Integration with external analytical services is not implemented in the current version). 

 

Figure 13. Analytical tab 
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 Registration and Submission - allows users to send batches to the registration service and 
receive registration status as assigned Conversational batch number, review batch details 

provided on the Batch Tab, and create a CD file. 

 

Figure 14. Registration & Submission tab 

 Attachments – allows uploading documents as attachments to an experiment using Options -> 
Add New Document. 

 

Figure 15. Adding documents on the Attachments tab 
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3.2.1. Managing Reagent Lists 

On the Experiments tab, users can create a personal list of reagents. To add a reagent to My Reagent 
list, users should right-click anywhere in the Stoichiometry Table section and then click Add To My 
Reagent List on the pop-up menu. To see the list, users need to click the My Reagent List tab: 

 

Figure 16. My Reagents List 

 CREATING SINGLETON EXPERIMENTS 

There are three ways to create a new experiment: 

 Create a new blank experiment, see Section 3.3.1. 

 Repeat an existing experiment, in which case only the information on the Experiment tab is 
copied, see Section 3.3.2. 

 Create a new version of an existing experiment, in which case all information from all the tabs 
is copied, see Section 3.3.3. 

3.3.1. Setting up a New Singleton Experiment 

To create a new blank experiment: 

1. In the navigation pane, right-click the node where you want to place the experiment and click 
Create New Experiment > Singleton Chemistry on the pop-up menu. 

 

Figure 17. Creating a Singleton experiment 
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Figure 18. Creating a blank experiment 

2. On the Experiments tab, in the Reaction Details section, provide a descriptive title and 
detailed information about the experiment. 

3. Double-clicking the Reaction Scheme area invokes the structure drawing editor specified in the 
Preferences dialog. You can right-click this area to invoke the menu with more options. 

4. Use the Stoichiometry Table to provide data about the reaction participants. 
5. Use the Reaction and Workup Procedure section to describe the procedure of the experiment, 

insert tables, images, and other objects, as necessary. 
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Note 
The text editor in the Reaction and Workup Procedure section provides standard text editing 
funcitons. 
To use special editing functions of the program, right-click the text to display the menu: 

 

Figure 19. Text editing menu 

The Reaction Scheme and Stoichiometry Table sections are related to each other and thus users can 

populate them using one of the two methods: 

 

Figure 20. Methods of populating Stoichiometry Table and Reaction Scheme 

Method A. Reaction Scheme > Stoichiometry Table 

1. Draw the reaction scheme using a structure editor. 

Note: 
Users select the structure editor to use in the Preferences window, see Section 2.5.1. 

2. In the Stoichiometry Table section, click Analyze Rxn to create the corresponding rows in the 
Stoichiometry Table. 

3. Add other solvents and reagents to the Stoichiometry Table. 
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Method B. Stoichiometry Table > Reaction Scheme 

1. Enter reactants, solvents, and reagents into the Stoichiometry Table. 
2. In the Stoichiometry Table section, click Create Rxn to create reactant structures. 
3. Edit the reaction scheme to add intended products. 
4. In the Stoichiometry Table section, click Analyze Rxn to create a row for the intended 

products. 

3.3.2. Repeating an Experiment 

Users can repeat anyone’s experiment by right-clicking the experiment, and then clicking Repeat this 
Experiment. This creates in the user`s notebook an experiment with the next sequence number and a 
copy of the data on the Experiments tab only. The data from the Batches, Analytical, Registration, and 
Attachments tabs are not copied, because those results tend to be different from the original. 

Note 
Make sure to edit any data that are not relevant to the new experiment in every section of the 
experiment - reaction scheme, stoichiometry, procedure & workup. Pay particular attention to 
product batch links: the copy refers to the original experiment batches. 

3.3.3. Versioning an Experiment 

Users can only make new versions of their own experiments. This is useful when users need to correct 
erroneous data or to add new data that was obtained after closing the original experiment (for 

example, analytical results). Initially, the new version has all the data of the original experiment. 

Other users can only see the newest version, while the author can see all of the versions. 

All versions must be completed and signed-off, leaving an IP record of all the work. 

Note 
Be sure to edit any data that are not relevant to the new experiment in every section of the 
experiment - reaction scheme, stoichiometry, procedure & workup. Pay particular attention to 
product batch links: the new version refers to the original experiment batches. 

 PRINTING EXPERIMENTS TO PDF 

Users can save the information about an experiment to a pdf file. To do this, right-click the experiment 
in the navigation pane and click Print this Experiment on the pop-up menu. The information is saved 
to a pdf file in C:/Documents and Settings/<USERName>/.IndigoELN/Printing-TMP/<ExperimentID>/. 

 RUNNING EXPERIMENT AND RECORDING RESULTS: BATCHES 

When users have a product batch, users can create it either in the Reaction & Workup Procedure 

section of the Experiments tab or on the Batches tab. 

3.5.1. Creating Batches on the Experiment Tab 

The advantage of creating a batch on the Experiments tab is that users can create a batch while 

describing the experiment procedure thus explaining how it was made. 
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Figure 21. Creating batches on the Experiments tab 

1. In the Reaction & Workup Procedure section, right-click inside the text area and click Create 
New Batch/Lot Entry on the pop-up menu. 

2. In the New Nbk Batch Entry window, select the Product checkbox if the batch is the intended 
product. The program calculates %yield for these batches if the other stoichiometry 
calculations have been made. If this is the intended product structure, select the 

corresponding value in the Batch Structure drop-down list. 

3.5.2. Creating Batches on the Batches Tab 

There are three ways to create batches on the Batches tab:  

 Synchronize with intended products by clicking the Sync with Intended Products button to 
create a batch for each intended product to the right of the reaction arrow. 

 Add a new batch by clicking the Add New Batch button or Add Batch on the pop-up menu to 
create an empty batch, for which users draw the structure. 

 Duplicate an existing batch by clicking Duplicate Batch on the pop-up menu. 

 

Figure 22. Batches menu 
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Users can also edit information in the Product Batch Details section as well as in the Product Nbk Batch 

Summary table that auto-synchronizes with the Details section: 

 

Figure 23. Product Batch area 

 REGISTERING AND SUBMITTING COMPOUNDS 

The program integrates with the registration and submission services. 

 

Figure 24. Registration features 
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Users can: 

1. Retrieve registration information for batches in the table; 
2. Submit all batches for registration at the same time; 
3. Browse the status of batches registration (unique batch # is assigned to the compound); 
4. Provide Purification Parameters to the Purification service; 

5. Select Submittal sets. 

 CREATING CONCEPTION RECORD PAGES 

Users can create a Conception Record page on the basis of: 

 A structure or reaction added by users in normal and generic format. 

 Design Synthesis Plan. 

To create a Conception record, right-click a folder and click Create New Experiment > Conception 
Record. The Work area displays three tabs: Concept, Preferred Compounds, and Attachments. 

The Concept tab provides the following functionality: 

 To identify Designers, click the People ( ) button next to the Designers section. 

 The Reaction Concept/Generic Target section can be used for either a reaction idea or an idea 
for a generic structure, whichever is the invention. 

 

Figure 25. Concept tab 
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On the Preferred Compounds tab, users can add compounds as specific examples of the generic 

structure. 

 

Figure 26. Preferred Compounds tab 

On the Attachments tab, to add or edit attached documents, users click Options and select the 

required item on the pop-up menu. 

 

Figure 27. Adding an attachment to a Conception Record 

 INDIGO ELN SEARCH 

There are four ways of searching structures in Indigo ELN: 

 Search from the Experiments tab; 

 Search using Options > Search; 

 Search for reactions using the Analyze Rxn feature; 

 Search in the fields of the Stoichiometry Table. 
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3.8.1. Search in the Database 

On the Experiments tab, click Search DBs to invoke the Lookup Reagents window: 

 

Figure 28. Lookup reagents window 

In fact, it is the second tab of the Lookup Reagents dialog. This dialog specifies search parameters. 
Users must select the Indigo ELN checkbox to display search options. Users can also double-click inside 
the rectangle in the lower-right corner to invoke the structure editor and draw a structure for 

Structure/Substructure/Similarity search. 

All text fields invoke search in the inner database of Indigo ELN. The structure field sends the query to 
the Search Service and retrieves Compound ID to search in the inner database of Indigo ELN. In case 
both structures and text fields are entered, first, the Search Service returns all Compound IDs, and 

then performs the search by text fields in the Indigo ELN database. 

To see the search results, click Search. The results appear in the third tab of the window: 

 

Figure 29. Display of search results 

Note 
Drawing a structure enables the search only among registered batches. 
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3.8.2. Search for Experiments 

You can search for experiments according to specified criteria. The search looks for experiments in the 
inner Indigo ELN database that includes a given compound or reaction together with selected text 
parameters. 

To search for experiments, click Options>Search to invoke the Query & Search dialog box, specify the 

search options, and click Search to display the Search Results window. 

 

Figure 30. Query & Search dialog box 

 

Figure 31. Search Results window 

3.8.3. Search for Reactions 

The Analyze Rxn feature searches for reactions in the Search Service by the structure of components. 

See Section 3.3.1 for details. 

3.8.4. Search in the Fields of the Stoichiometry Table 

Users can use the following fields of the Stoichiometry Table to search by typing the search options. 

Searching in the Search Service: 



Indigo ELN Version 1.2 User Guide  May 7, 2015 

  Confidential | 21 

 Compound ID 

 CAS Number 

Searching in Indigo ELN inner database: 

 Nbk Batch # 

To start the search, click inside the field and type the required value. 

 

Figure 32.Searching in fields of Stoichiometry table 

 SIGNING EXPERIMENTS 

EPAM ships Indigo ELN together with the eSignature service that provides tools to submit, sign, and 

archive experiments. To use the Signature Service: 

1. Complete the experiment by right-clicking the experiment and selecting Mark this Experiment 
Complete. 

 

Figure 33. Completing an experiment 
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Figure 34. Signing experiments 

2. Select the template and submit the experiment for signature. 

 

Figure 35. Selecting a template for signature 

3. Click OK.  
4. Further actions happen inside the Indigo Signature Service application. Follow the steps 

described in the Indigo Signature Service User Guide. 

Note 
Other signers in the queue sign or reject an experiment via the Indigo Signature Service UI. 
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Information about the experiment updates while it is undergoing the signing procedure. Users can see 

the status of the experiment when users point the cursor at the experiment in the Navigation pane: 

 

Figure 36. Signature status of an experiment 

The following are signing states: 

 Submitted – a new document is just uploaded to Indigo Signature and has no signatures 

 Signing – at least one signature is complete, but not all 

 Signed – all signatures are complete 

 Archiving – document is being archived 

 Archived – document is archived 

 Submit-Fail – document is rejected  

As the final stage of the signature process, the document is marked as archived. 

To see the signed version of an experiment, in the Navigation pane, right-click the experiment in 

Archived state and click View Record Archived. 

 

Figure 37. Signature status and viewing a signed experiment 
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